
 

 

 

 

 

Step by Step Guide of BI Case Study of MYSQL via Visual Studio Code 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



Contents 
Step by Step Guide of BI Case Study of MYSQL via Visual Studio Code ..................................................... 1 

Introduction of Case Study ..................................................................................................................... 3 

Step 1: Install MySQL environment .......................................................................................................... 4 

Step 2:  Installing MySQL for Visual Studio ............................................................................................... 5 

Step 3: Prepare Visual Studio 2015 environment ..................................................................................... 5 

Step 4: Create a project that contains a BDC model ................................................................................. 8 

Step 5: Install ODBC Driver ...................................................................................................................... 9 

Step 6: Creation of ODBC Connection ...................................................................................................... 9 

Step 7: Configure MYSQL connection in Visual Studio ............................................................................ 10 

Step 8: Understanding the BDC Model Architecture .............................................................................. 11 

Step 9: Remove the default entity from the BDC model ......................................................................... 12 

Step 10: Add an entity to the model ...................................................................................................... 13 

Step 11: Step Add a Specific Finder method ........................................................................................... 13 

Step 12: Add a finder method ................................................................................................................ 16 

Step 13: Test the project ....................................................................................................................... 18 

Step 14: Creating BI based on List .......................................................................................................... 19 

Output of Case Study ............................................................................................................................ 20 

 

 

 

 

 

 

 

 

 

 

 

 

 



Introduction of Case Study 
There is a build-in sample database with MySQL, that will be used for this case study. 

See details here: 

https://dev.mysql.com/doc/sakila/en/ 

Figure 1 The Sakila Schema 

 

https://dev.mysql.com/doc/sakila/en/


In Mysql WorkBench, sakita database looks like as: 

 

 

There is a Table of ACTOR, that will be used for this case study. 

 

Step 1: Install MySQL environment 
 

Go to following link: 

https://dev.mysql.com/downloads/mysql/5.6.html 

 

Download MSI package, and install MySQL Server by following default steps. 

After MySQL Installation, SharePoint 2016, Central administration and all sites collection, stop working. 

Investigating error in ULS logs show following error: 

Application error when access /default.aspx, Error=The connection string name is missing for the MySqlSiteMapProvider   
 at MySql.Web.SiteMap.MySqlSiteMapProvider.Initialize(String name, NameValueCollection config)     
 at System.Web.Configuration.ProvidersHelper.InstantiateProvider(ProviderSettings providerSettings, Type providerType)  

 

Solution:  

Central administration, has web site in IIS. Suppose your central administration pot is 39805, then 

your web site will be located at following location. 

https://dev.mysql.com/downloads/mysql/5.6.html


C:\inetpub\wwwroot\wss\VirtualDirectories\39805 

You have to add the following code to the web.config file : 
 

<system.web> 
 ... 
  <siteMap 
    <providers>    
        <remove name="MySqlSiteMapProvider" /> 
    </providers> 
  </siteMap> 
</system.web> 

Similarly, for all web applications, in SharePoint, see the port of web application. For each web 

application, see the virtual directory as below. 

C:\inetpub\wwwroot\wss\VirtualDirectories\XXX 

Where XXX, is the port of web application of SharePoint environment. 

After these web.config changes, Central administration and all site collection, starts working properly. 

 

Step 2:  Installing MySQL for Visual Studio 
Go to following link, and install MySQL for Visual studio. 

https://dev.mysql.com/downloads/windows/visualstudio/ 

 

MySQL for Visual Studio provides access to MySQL objects and data using Microsoft Visual Studio. 

MySQL for Visual Studio provides: 

 

 Design Time Support 

 Query Designer 

 Stored Routine Debugging 

 Entity Framework 

 

Step 3: Prepare Visual Studio 2015 environment 
Install Visual Studio 2015 professional or Enterprise with custom option such that “Office tools for Visual 

studio 2015”, is selected. 

 

Show stopper Scenario 

Although we have installed Microsoft Office Developer Tools for Visual Studio 2015, and the Office / 

SharePoint Template is shown in the New Project dialog. However, we can’t find SharePoint 2016 

https://dev.mysql.com/downloads/windows/visualstudio/


Project Template as shown below： 

 

 

 

Cause 

This issue usually occurs in case the Microsoft Office Developer Tools Preview 2  for Visual Studio 2015 

is not installed. 

 

Resolution 

Download Microsoft Office Developer Tools Preview 2  for Visual Studio 2015. 

 

https://www.microsoft.com/en-us/download/details.aspx?id=51683
https://www.microsoft.com/en-us/download/details.aspx?id=51683
https://www.microsoft.com/en-us/download/details.aspx?id=51683
https://www.microsoft.com/en-us/download/details.aspx?id=51683


 Select the file name based on your language. 

 

 After the file is downloaded. Double-click the file to install the office/SharePoint Tools > Install. 
 After the installation process is completed, open Visual Studio 2015 > New Project > expand the 

preferred language. 
 The Office / SharePoint Template should be now listed with SharePoint 2016 Project Template. 

 

 



Step 4: Create a project that contains a BDC model 
 

1. On the menu bar in Visual Studio, choose File > New > Project. 

The New Project dialog box opens. 

2. Under either Visual C# or Visual Basic, expand the SharePoint node, and then 

choose the 2010 item. 

3. In the Templates pane, choose SharePoint 2016 Empty Project, name the 

project MysqlExternalCTSolution, and then choose the OK button. 

The SharePoint Customization Wizard appears. In this wizard, you can specify 

the site that you'll use to debug the project and set the trust level of the solution. 

4. Choose the Deploy as a farm solution option button to set the trust level. 

5. Choose the Finish button to accept the default local SharePoint site. 

6. In Solution Explorer, choose the SharePoint project node. 

7. On the menu bar, choose Project > Add New Item. 

The Add New Item dialog box opens. 

8. In the Templates pane, choose Business Data Connectivity Model (Farm 

Solution Only), name the project MySQLExternalCT, and then choose the Add 

button. 
 

As show below: 



 

 

Step 5: Install ODBC Driver 
Go to following URL: 

https://downloads.mysql.com/archives/c-odbc/ 

 

and install 32 bit ODBC driver for MYSQL(8.0.xx). Follow instructions with default settings. 

 

Step 6: Creation of ODBC Connection 
Go to Control Panel >> Administrative tools, open “ODBC Data Source 32”. 

Configure properties of data source as below screen. 

 

https://downloads.mysql.com/archives/c-odbc/


 

 

Step 7: Configure MYSQL connection in Visual Studio 
In visual studio, Go to Tools >> Nuget Packacge  Manager >> Package Manager Console. 

Run following command: 

Install-Package MySql.Data.Entity -Version 6.9.9 

Make sure, it complete successfully. 

 

In Visual Studio, configure connection to sakita database of mysql as below. 



 

 

 

 

 

 

 

 

 

Step 8: Understanding the BDC Model Architecture 
Visual Studio adds the following files to the new folder: 

File Description 

Model Definition 

File 

Contains XML that defines the entities, methods, Line of Business (LOB) system objects, 

and other metadata that describes the model. 

 



File Description 

Modify the metadata in this file by using the BDC Designer, BDC Explorer, BDC Method 

Detailswindow, and Properties window. 

Entity Service 

Code File 
Contains methods that retrieve, update, and delete instances of the default entity. 

 

To define the properties of an entity, edit the entity code file. For more information, 

see How to: Add an entity to a model. 

To retrieve, update, and delete instances of an entity, add code to the entity service 

code file. For more information, see Designing a business data connectivity model. 

When you compile the project, Visual Studio creates an assembly. Ensure that you do 

not add other items to the project that add code to the project assembly (For example: 

a Sequential Workflow item or a Web Part item). The code for that item will not run 

when you deploy the solution because the solution package does not copy the 

assembly to the global assembly cache. The solution package deploys the assembly to 

the BDC database in SharePoint only. 

 

Step 9: Remove the default entity from the BDC model 

The Business Data Connectivity Model project adds a default entity named Entity1 to 

the model. Remove this entity. Later, you will add a new entity. Starting with an empty 

model reduces the number of steps required to complete the walkthrough. 

1. In Solution Explorer, expand the BdcModel1 node, and then open the 

BdcModel1.bdcm file. 

2. The Business Data Connectivity model file opens in the BDC designer. 

3. In the designer, open the shortcut menu for Entity1, and then choose Delete. 

4. In Solution Explorer, open the shortcut menu for Entity1.vb (in Visual Basic) or 

Entity1.cs (in C#), and then choose Delete. 

https://github.com/MicrosoftDocs/visualstudio-docs/blob/master/docs/sharepoint/how-to-add-an-entity-to-a-model.md
https://github.com/MicrosoftDocs/visualstudio-docs/blob/master/docs/sharepoint/designing-a-business-data-connectivity-model.md


5. Open the shortcut menu for Entity1Service.vb (in Visual Basic) or Entity1Service.cs 

(in C#), and then choose Delete. 
 

 

Step 10: Add an entity to the model 

Add an entity to the model. You can add entities from the Visual Studio Toolbox onto 

the BDC designer. 

1. On the menu bar, choose View > Toolbox. 

2. On the BusinessDataConnectivity tab of the Toolbox, add an Entity onto the 

BDC designer. 

The new entity appears on the designer. Visual Studio adds a file that's named 

EntityService.cs (in C#) to the project. 

3. On the menu bar, choose View > Properties > Window. 

4. In the Properties window, set the Name property value to Actor. 

5. On the designer, open the shortcut menu for the entity, choose Add, and then 

choose Identifier. 

A new identifier appears on the entity. 

6. In the Properties window, change the name of the identifier to ActorID. 

7. In the Type Name list, choose System.Int32. 
 

 

Step 11: Step Add a Specific Finder method 

To enable the BDC service to display a specific Actor, you must add a Specific Finder 

method. The BDC service calls the Specific Finder method when a user chooses an item 

in a list and then chooses the View Item button on the Ribbon. 

Add a Specific Finder method to the Actor entity by using the BDC Method Details 

window. To return a specific entity, add code to the method. 

1. On the BDC designer, choose the Actor entity. 



2. On the menu bar, choose View > Other Windows > BDC Method Details. 

The BDC Method Details window opens. 

3. In the Add a Method list, choose Create Specific Finder Method. 

Visual Studio adds the following elements to the model. These elements appear in 

the BDC Method Details window. 

 A method named ReadItem. 

 An input parameter for the method. 

 A return parameter for the method. 

 A type descriptor for each parameter. 

 A method instance for the method. 

4. In the BDC Method Details window, open the list that appears for the Actor type 

descriptor, and then choose Edit. 

The BDC Explorer opens and provides a hierarchical view of the model. 

5. In the Properties window, open the list next to the TypeName property, choose 

the Current Project tab, and then choose the Actor property. 

6. In the BDC Explorer, open the shortcut menu of the Actor, and then choose Add 

Type Descriptor. 

A new type descriptor that's named TypeDescriptor1 appears in the BDC 

Explorer. 

7. In the Properties window, set the Name property value to ActorID. 

8. Open the list next to the TypeName property, and then choose Int32. 

9. Open the list next to the Identifier property, and then choose ActorID. 

10. Repeat step 6 to create a type descriptor for each of the following fields. 



Name Type Name 

FirstName System.String 

LastName System.String 

LastUpdates System.DateTime 

11. In the BDC designer, on the Actor entity, open the ReadItem method. 

The Actor service code file opens in Code Editor. 

12. In the ActorService  class, replace the ReadItem  method with the following code. 

This code performs the following tasks: 

 Retrieves a record from Actor table of the Sakita database. 

 Returns a Actor entity to the BDC service. 

C#  

public static Actor ReadItem(string id) 

        { 

            MySqlConnection con = new MySqlConnection(ConnectionString); 

 

            con.Open(); 

 

            MySqlCommand cmd = new MySqlCommand("select * from actor where 

actor_id="+ id, con); 

            MySqlDataAdapter adp = new MySqlDataAdapter(cmd); 

            DataSet ds = new DataSet(); 

            adp.Fill(ds); 

 

               DataRow dr = ds.Tables[0].Rows[0] ; 



               Actor actor = new Actor(); 

                actor.ActorID = dr["actor_id"].ToString(); 

                actor.FirstName = dr["first_name"].ToString(); 

                actor.LastName = dr["last_name"].ToString(); 

                DateTime myDate; 

                if (!DateTime.TryParse(dr["last_update"].ToString(), out myDate)) 

                { 

                    actor.LastUpdate = DateTime.Now; 

                } 

                else 

                { 

                    actor.LastUpdate = myDate; 

                } 

              

            cmd.Dispose(); 

 

            return actor; 

        } 

 

Note: 

Define a connection string variable in ActorServices.cs 

static string ConnectionString = "server=127.0.0.1;user 
id=root;password=abcd@1234;persistsecurityinfo=True;database=sakila;allowuservariables=Tr
ue"; 
 

Replace variable with cases according to your cases. 

 

Step 12: Add a finder method 

To enable the BDC service to display the Actor in a list, you must add a Finder method. 

Add a Finder method to the Actor entity by using the BDC Method Details window. To 

return a collection of entities to the BDC service, add code to the method. 



1. In the BDC designer, choose the Actor entity. 

2. In the BDC Method Details window, collapse the ReadItem node. 

3. In the Add a Method list under the ReadList method, choose Create Finder 

Method. 

Visual Studio adds a method, a return parameter, and a type descriptor. 

4. In the BDC designer, on the Actor entity, open the ReadList method. 

The code file for the Actor service opens in Code Editor. 

5. In the ActorService  class, replace the ReadList  method with the following code. 

This code performs the following tasks: 

 Retrieves data from the Actor table of the Sakita database. 

 Returns a list of Actor entities to the BDC service. 

C# 

public static IEnumerable<Actor> ReadList() 
        { 
                List<Actor> actorList = new List<Actor>(); 
            MySqlConnection con = new MySqlConnection(ConnectionString); 
 
            con.Open(); 
 
            MySqlCommand cmd = new MySqlCommand("select * from actor", con); 
            MySqlDataAdapter adp = new MySqlDataAdapter(cmd); 
            DataSet ds = new DataSet(); 
            adp.Fill(ds); 
 
            foreach (DataRow dr in ds.Tables[0].Rows) 
            { 
                Actor actor = new Actor(); 
                actor.ActorID = dr["actor_id"].ToString(); 
                actor.FirstName = dr["first_name"].ToString(); 
                actor.LastName = dr["last_name"].ToString(); 
                DateTime myDate; 
                if (!DateTime.TryParse(dr["last_update"].ToString(), out myDate)) 
                { 
                    actor.LastUpdate = DateTime.Now; 
                } 
                else 
                { 
                    actor.LastUpdate = myDate; 
                } 
                actorList.Add(actor); 
            } 



            cmd.Dispose(); 
 
            return actorList.AsEnumerable<Actor>(); 

        } 

 

 

Step 13: Test the project 

When you run the project, the SharePoint site opens and Visual Studio adds your model 

to the Business Data Connectivity service. Create an external list in SharePoint that 

references the Actor entity. The data for Actor in the Sakita database appear in the list. 

Note 

You might have to modify your security settings in SharePoint before you can debug 

your solution. For more information, see Design a business data connectivity model. 

1. Choose the F5 key. 

The SharePoint site opens. 

2. On the Site Actions menu, choose the More Options command. 

3. On the Create page, choose the External List template, and then choose the 

Create button. 

4. Name the custom list Actor. 

5. Choose the browse button next to the External Content Type field. 

6. In the External Content Type Picker dialog box, choose the 

MysqlExternalCTSolution.MySQLExternalCT.Actor item, and then choose the 

Create button. 

SharePoint creates an external list that contains Actors from the Sakita sample 

database. 

7. To test the Specific Finder method, choose a Actor in the list. 

8. On the Ribbon, choose the Items tab, and then choose the View Item command. 

The details of the Actors that you chose appear on a form. 
 

https://docs.microsoft.com/en-us/visualstudio/sharepoint/designing-a-business-data-connectivity-model?view=vs-2017


 

Step 14: Creating BI based on List 
 

SharePoint 2016: Chart Web Part Missing 

Login to any farm server hosting SharePoint as a Site Collection Administrator. 

1. Go to: Settings > Site Settings > Go to top level site settings > Web Designer Galleries > Web 
parts. 
 

2. Click the FILES tab. 
 

3. Click New Document. 
 

4. Scoll down the list and look for: Microsoft.Office.Server.WebControls.ChartWebPart. 
 

5. Check this item. 
 

6. Scroll back up to the top, and then click the Populate Gallery button. 
 

7. Wait for it to refresh. 
 

8. Scoll down the list and look for: ChartWebPart.webpart. 
 

9. Click its Edit button. 
 

10. Enter the value, Content Rollup, or enter any other web part group value appropriate to your 
needs. 
Click Save. 
 

11. That's it. The next time you open a web page in edit mode and search for a web part to add to it, 
you'll see the Chart web part there. 

Insert a Chart web part as below: 



 

 

Connect to Configuration wizard of Chart web part , to configure data source to newly created list, 

secondly, configure properties of chart. 

 

 

 

Output of Case Study 
Following different chart are created with actor table of Mysql database named Sakita. 

 

 

 

 



 

 



 



 



 



 



 


